need help with port forwarding

Oct 5, 2018
7
0
1
17
#5
You have to be specific as to "play with friends"
If they are on same network then you dont need to port forward

Read the faq here first
https://halo2.online/help/install/
I mean I want to play with some friends who are on the same network, and also some that are on a different network. I logged into the router and attempted the port forwarding. It does not work. Is there something I have to edit in the "halo2config1.ini" file?
And also I will add a screencap of the settings in the router, so you can tell if there is an issue there.
 

mills

Staff
Project Cartographer Staff
May 10, 2017
265
25
28
#6
(1) the ip address in the router config needs to be set to YOUR local ip address (found by typing "ipconfig" in the command prompt)
(2) you have selected the TCP protocol; it needs to be the UDP protocol
(3) if you want people on your network to be able to join you need to open halo2config1.ini on EACH pc and set up the following:
  • (a) make sure every pc has a different base_port setting, we suggest using 2000 (on the host), 3000, 4000, 5000, etc
  • (b) set your LAN_IP setting to the local ip of the pc that is being configured (the ip found by typing "ipconfig" in the command prompt
https://mega.nz/#!YcsADKbK!VH8pM9N1dKhGpOZw2LCua322dDz0akVcFmC8jVN5jX8 this tool may make it easier for you
 
Oct 5, 2018
7
0
1
17
#7
(1) the ip address in the router config needs to be set to YOUR local ip address (found by typing "ipconfig" in the command prompt)
(2) you have selected the TCP protocol; it needs to be the UDP protocol
(3) if you want people on your network to be able to join you need to open halo2config1.ini on EACH pc and set up the following:
  • (a) make sure every pc has a different base_port setting, we suggest using 2000 (on the host), 3000, 4000, 5000, etc
  • (b) set your LAN_IP setting to the local ip of the pc that is being configured (the ip found by typing "ipconfig" in the command prompt
https://mega.nz/#!YcsADKbK!VH8pM9N1dKhGpOZw2LCua322dDz0akVcFmC8jVN5jX8 this tool may make it easier for you
Changed the protocol from TCP to UDP, changed the IP if the Port Forwarding section to my Local IP. Still nobody can join the game.
 

Himanshu01

Lead Dev
Project Cartographer Staff
May 16, 2013
231
18
18
20
India
Gamertag
Himanshu01
#8
(1) the ip address in the router config needs to be set to YOUR local ip address (found by typing "ipconfig" in the command prompt)
(2) you have selected the TCP protocol; it needs to be the UDP protocol
(3) if you want people on your network to be able to join you need to open halo2config1.ini on EACH pc and set up the following:
  • (a) make sure every pc has a different base_port setting, we suggest using 2000 (on the host), 3000, 4000, 5000, etc
  • (b) set your LAN_IP setting to the local ip of the pc that is being configured (the ip found by typing "ipconfig" in the command prompt
https://mega.nz/#!YcsADKbK!VH8pM9N1dKhGpOZw2LCua322dDz0akVcFmC8jVN5jX8 this tool may make it easier for you
Yup thats all you need
 
Oct 5, 2018
7
0
1
17
#9
Can somebody tell me what I have done wrong here? I have tried the best I can to follow your instructions. But I still can't get it to work. Thanls in advance.
 
Last edited:

mills

Staff
Project Cartographer Staff
May 10, 2017
265
25
28
#10
oh boy
try setting the WAN_IP setting to the ip address found on http://www.whatsmyip.com - it may be that the tool filled in the 0.0.0.0 setting (which would make your game unjoinable). this needs to be done on every pc on your network
 
Oct 5, 2018
7
0
1
17
#11
oh boy
try setting the WAN_IP setting to the ip address found on http://www.whatsmyip.com - it may be that the tool filled in the 0.0.0.0 setting (which would make your game unjoinable). this needs to be done on every pc on your network

Changed the the WAN_IP setting from 0.0.0.0 to the IP provided by www.whatsmyip.com, but players from other networks are still unable to join me. And when I create a game a "lock" appears next to Slayer. Altough the lobby is "Open".
 

Himanshu01

Lead Dev
Project Cartographer Staff
May 16, 2013
231
18
18
20
India
Gamertag
Himanshu01
#12
That lock signifies that its a Custom Game
Although I assume it signified Gold Only in GFWL days,which makes sense

In short the lock is nothing to do with your unable to hosting
 

mills

Staff
Project Cartographer Staff
May 10, 2017
265
25
28
#14
Changed the the WAN_IP setting from 0.0.0.0 to the IP provided by www.whatsmyip.com, but players from other networks are still unable to join me. And when I create a game a "lock" appears next to Slayer. Altough the lobby is "Open".
if people from other networks can't join, then it means you haven't port forwarded correctly or something is wrong with the port forwarding

don't know what it could be except maybe a software firewall
 
Oct 5, 2018
7
0
1
17
#15
I have run the port checker (Port Forward Network Utilites), and the ports appear to be closed. I have tried to port forward using this application but without result. Is this because I only have the "Trial" version? And also, how do I check that Project Cartographer is allowed through ALL firewalls?
 

mills

Staff
Project Cartographer Staff
May 10, 2017
265
25
28
#16
I have run the port checker (Port Forward Network Utilites), and the ports appear to be closed. I have tried to port forward using this application but without result. Is this because I only have the "Trial" version? And also, how do I check that Project Cartographer is allowed through ALL firewalls?
depends on your pc, i can't do any more than this